Back
Maintenance

Server Maintenance

Completed 18 Aug at 07:45am EDT.

jinxxy.com
Completed

Maintenance completed

Posted 18 Aug at 07:45am EDT.
Started

We are deploying a maintenance update to all our servers which will cause the site to be offline for a few mins.

Posted 18 Aug at 07:15am EDT.