Back
Degraded
Degraded
Catalog Service delayed across all platforms.
Started 4 Oct at 02:30am EDT, resolved 4 Oct at 04:52am EDT.
Gumroad Catalog
Payhip Catalog
Shopify Catalog
Sellify Catalog
Resolved
Catalog service is back to normal
Posted 4 Oct at 04:52am EDT.
Created
The catalog service is currently delayed. Product updates may take longer to update than normal.
Posted 4 Oct at 02:30am EDT.