Back
Maintenance

Server Maintenance

Completed 25 Jan at 04:00am EST.

jinxxy.com
Completed

Maintenance completed

Posted 25 Jan at 04:00am EST.
Started

We are currently migrating and adjusting our servers. The website may go offline or show errors throughout the day.

We are trying to minimize this downtime and will close out this status when we are done.

Posted 24 Jan at 05:00pm EST.